Advertisements

Solution: Microsoft Flow error “The query to field ‘/fieldname/LinkTitleNoMenu’ is not valid”

I recently ran into the following error message in Microsoft Flow that was triggered by a SharePoint – modified list item flow: “The query to field ‘/fieldname/LinkTitleNoMenu’ is not valid.” You’ll see this message in some cases when lookup columns are being utilized on the lists you’re referencing in Microsoft Flow.

This error was caused, at least for me, as a result of setting my “destination” list’s lookup column setting to display as Title (linked to item) instead of just Title. The following details the steps involved in fixing it.

If you have lookup columns in multiple lists involved in your Flow, repeat this as many times as necessary to troubleshoot your issue. Then try to run your Flow again (and you may just double check that the changes you’ve made didn’t affect your dynamic content references. I typically wipe out any fields I change and “reconnect” just in case).

  1. Go to List Settings on the list with lookup column(s)
  2. Under “columns” select your first lookup column
  3. From the “in this column” dropdown, make sure your column is set to “Title,” not “Title (linked to item).”
    lookupcolumnsetting
  4. Click OK and repeat for any other lookup columns on your Flow-related lists

Good luck! I hope this fixes the error for you too.

 

Advertisements

5 Comments

  1. Daz

    Reply

    Hi, Unfortunately this does not seem to be working for me. I have followed the steps and am having the same error occur. Do you know of anything else that may cause this error?
    Thanks,
    Daz

    • Reply

      Hi Daz, if you’re sure you changed every lookup column’s settings to Title, I’m not sure. It’s the same LinkTitleNoMenu error? And did you make sure, after changing the column settings, that your Flow is still “in tact” referencing the lookup columns correctly?

      • Reply

        Even I was having issue as Daz’s. I had additional fields added from lookup and I believe that was causing the issue. I just recreate new lookup field (title without link) , add additional columns and it worked.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: